ACME Corp

ACME Corp

ACME Corp Status

Real-time status and incident updates for ACME Corporation services

Product Catalog Search Degradation

Resolved Minor
Started:
Resolved:

Affected Components

E-commerce Platform
Product Catalog API Product information and search API
Operational

Updates Timeline (3 updates)

Resolved

Search index rebuild complete. Product search is now performing normally.

Identified

Search index has become fragmented due to recent bulk product imports. Rebuilding indexes now.

Investigating

Some customers are reporting slow search results in the product catalog. We are investigating.