ACME Corp

ACME Corp

ACME Corp Status

Real-time status and incident updates for ACME Corporation services

CDN Cache Invalidation Issues

Resolved Major
Started:
Resolved:

Affected Components

E-commerce Platform
Website & Shopping Cart Main e-commerce website and cart functionality
Operational
Product Catalog API Product information and search API
Operational

Updates Timeline (4 updates)

Resolved

Cache invalidation is working normally. All customers should now see current product information.

Monitoring

CDN has acknowledged the issue and is implementing a fix. We are manually purging critical content.

Identified

Our CDN provider is experiencing cache invalidation delays across multiple edge locations. Working with their support team.

Investigating

Customers are seeing outdated product information and pricing on the website. We are investigating cache-related issues.