Product Image CDN Degradation
Resolved
Minor
Started:
Resolved:
Affected Components
E-commerce Platform
Website & Shopping Cart
Main e-commerce website and cart functionality
Operational
Product Catalog API
Product information and search API
Operational
Updates Timeline (3 updates)
Resolved
Image CDN origin scaled. Product images are loading normally across all regions.
Identified
Image CDN origin server is overloaded. Scaling up origin capacity.
Investigating
Product images are loading slowly or showing placeholder images on some pages.