Payment Gateway SSL Certificate Expiry
Resolved
Major
Started:
Resolved:
Affected Components
Payment Processing
Payment Gateway
Credit card and payment processing
Operational
Billing System
Invoice generation and subscription management
Operational
Updates Timeline (4 updates)
Resolved
Payment gateway fully operational. We have implemented automated certificate monitoring to prevent future lapses.
Monitoring
New certificate installed and propagating. Payment processing is being restored.
Identified
An SSL certificate for our payment gateway has unexpectedly expired. We are working with our certificate authority to issue an emergency renewal.
Investigating
Payment processing is currently unavailable. Customers are unable to complete checkout. We are investigating urgently.